sexta-feira, 5 de janeiro de 2018

Debian libera correção do kernel para processadores Intel

A comunidade Debian liberou correção para a falha Meltdown” (CVE-2017-5754).
Veja os detalhes nessa matéria.








Comunicado

Debian Security Advisory DSA-4078-1 security@debian.org https://www.debian.org/security/ Yves-Alexis Perez January 04, 2018 https://www.debian.org/security/faq - ------------------------------------------------------------------------- Package : linux CVE ID : CVE-2017-5754 

Multiple researchers have discovered a vulnerability in Intel processors, enabling an attacker controlling an unprivileged process to read memory from arbitrary addresses, including from the kernel and all other processes running on the system. This specific attack has been named Meltdown and is addressed in the Linux kernel for the Intel x86-64 architecture by a patch set named Kernel Page Table Isolation, enforcing a near complete separation of the kernel and userspace address maps and preventing the attack. This solution might have a performance impact, and can be disabled at boot time by passing `pti=off' to the kernel command line. We also identified a regression for ancient userspaces using the vsyscall interface, for example chroot and containers using (e)glibc 2.13 and older, including those based on Debian 7 or RHEL/CentOS 6. This regression will be fixed in a later update. The other vulnerabilities (named Spectre) published at the same time are not addressed in this update and will be fixed in a later update. For the oldstable distribution (jessie), this problem will be fixed in a separate update. For the stable distribution (stretch), this problem has been fixed in version 4.9.65-3+deb9u2. We recommend that you upgrade your linux packages. For the detailed security status of linux please refer to its security tracker page at: https://security-tracker.debian.org/tracker/linux Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/ Mailing list: debian-security-announce@lists.debian.org -----BEGIN PGP SIGNATURE----- iQEzBAEBCgAdFiEE8vi34Qgfo83x35gF3rYcyPpXRFsFAlpOqZMACgkQ3rYcyPpX RFuTTQf/btBqg9/I3XlnJFyGAmd4eQolTcU5cfDJqNhD4TZoyMocghvw1kYtu7z9 bYVhwCRukJym8O8AXJOxvlcsP7g0ANXqVDHpzCN8byKYgzigVP9brfOu/zDa4uYY EYf8V3pc2QzNo5OV4G+sK5ZklkDnNIde+OxUfU0Otl9fUG2rS5JTFvaRgvGazlbb cN5wltoHD6DBeSRnfadwYPHQR5U+KAJNImh34Y6T73i7n5dGTnNhs6E7n0wlJL9O SQLwoqQeiDpcE7C4TZ1pb4AbFCZXaic+1ONbWy8D7erKNA7kV1U2LQDmPDw9kmua Lc5heEX026Xfdy83v6NAPwR+NU8stg== =GGyG -----END PGP SIGNATURE-----





Fonte

Atualização

Apenas para Debian Stable ( Stretch) as demais ainda não foram corrigidas, portanto se instalou kernel do backports e deseja ter a correção, instale o kernel indicado nessa matéria ou aguarde a correção para a sua versão do kernel.

Apenas para Debian Stable ( Stretch )


Para ter seu sistema com a correção, um simples upgrade não ira resolver, pois a versão atual é a 

linux-image-4.9.0-4-amd64 (4.9.65-3+deb9u1)




E a correção se encontra no kernel.

linux-image-4.9.0-5-amd64 (4.9.65-3+deb9u2)

Mas você deve atualizar o sistema antes para evitar problemas, no terminal de o comando abaixo.

sudo apt update

sudo apt full-upgrade


Para instalar o kernel corrigido com o comando abaixo no terminal para a sua arquitetura.

Para amd64 (64 bitis )

sudo apt install linux-image-4.9.0-5-amd64 linux-headers-4.9.0-5-amd64

Para i386 ( 32 bits )

sudo apt install linux-image-4.9.0-5-686 linux-headers-4.9.0-5-686

Feita a instalação, reinicie o computador e seu sistema já estará com proteção a falha (CVE-2017-5754)

Consumo de recursos antes da atualização.







Consumo de recursos apos a atualização.




OBS: Aqui teve uma demora para entrar no lightdm, portanto se ocorrer com você, aguarde ...


O teste foi feito em Vm com adicionais para convidado instalado e não tive problemas com ele, portanto é bem provável que vc não tenha problemas com firmware proprietária de Vídeo caso esteja usando.

Quanto a vulnerabilidade Spectre” (CVE-2017-5753 and CVE-2017-5715) aguarde que iremos informar assim que saírem.


Atualizado em 06/01/2018

Apenas para Debian Unstable (SID)

Debian unstable acaba de receber a correção para Meltdown” (CVE-2017-5754).



Para ter o seu kernel com a correção no Debian SID, de o comando abaixo no terminal.

Para arquitetura amd64 ( 64 bits )

sudo apt install linux-image-4.14.0-3-amd64 linux-headers-4.14.0-3-amd64

Para arquitetura i386 ( 32 bits )

sudo apt install linux-image-4.14.0-3-686 linux-headers-4.14.0-3-686

Reinicie a maquina para carregar o novo kernel.

Recomendação pós atualização


Apos a instalação do novo kernel e reinicialização do sistema, leia essa matéria.

Remover versões antigas do kernel Linux, para Debian, Ubuntu e derivados


Donate - Contribua para a melhoria do nosso trabalho!!







Nenhum comentário:

Postar um comentário

Para tirar dúvidas utilize o nosso fórum (https://linuxdicasesuporte.blogspot.com.br/p/document.html)